PLAYERS SETTINGS

For MAC users we recommend Audirvana or Pure Music.

Audirvana configuration

DAC: 32/384kHz

1. On top Bar click Audirvana Plus menu and verify iTunes Integrated mode is not
checked

of T L0l File Edit Play Window Help
About Audirvana Plus : i ol

Debug Info...

Preferences... %,
Check for Updates...
Load License File ...

Services
iTunes Integrated Mode

Hide Audiwana Plus  #H
Hide Others X #H
Show All

Quit Audirvana Plus  %Q

DAC: 32/384kHz
o0 ————————————— ]




2. Select Audirvana Plus >Preferences

ﬂ LU PV PR Tl File Edit Play Window Help
About Audirvana Plus

Debug Info...

Preferences...
Check for Updates...
Load License File ...

Services
iTunes Integrated Mode

Hide Audirvana Plus  38H
Hide Others #H
Show All

Quit Audirvana Plus  3Q

3. In Audio system window ensure you have set PCM-DSD USB Audio interface as
output device:

® Audirvana Plus File Edit Play Window Help
8006 Audirvana Preferences

Y ) m @

| Audio Filters Audio Volume SysOptimizer iTunes

Preferred Audio Device
PCM-DSD USB Audio Interface | Change |

Activek'Audio Device
PCM-DSD USB Audio Interface
441 48 882 96 176.4 192

Native DSD Capability | DSD over PCM standard 1.0 3 |

384.0 DSD64 DSD128

Low level playback options

EI Exclusive access mode
[21 Direct Mode

EI Integer mode (if avail. on device)

Maximum memory allocated for tracks pre-load

- e > 2048 MB
50mn @44.1kHz Smn @384kHz

For bridge devices connected to a DAC

Max sample rate limit| No Limit % | Spl rate switching latency 4s




4. In addition we recommend to set player in this way:

_‘ Audirvana Plus File FEdit Play Window Help
[ HsNG] Audirvana Preferences

B D) m

Audio System  Audio Filters Audio Volume SysOptimizer Tunes

Remote control
E Use Apple IR Remote

x [21 Use keyboard media keys

v ™ for volume control

Playlists
EI Use UTF-8 character encoding for M3U playlists
[ Autostart playback when opened from outside

™ Reload last playlist at start

Volume Control
Mouse control axis: | Rotation

Application updates

Iy

™ Automatically check for updates | Daily * |
[ | Automatically download updates

General window

# AudirvanaPlus File Edit Play Window Help
eo0o Audirvana Preferences

s
\I))) [
| Audio Volume SysOptimizer iTunes

A )
i 1
‘General Audio System | /

Sample Rate Conversion (8
Converter: | iZotope 64-bit SRC

Quality T

Fastest Best

» Advanced parameters

Forced Upsampling: (s) None
': | Power of 2 oversampling only (2x, 4x, ...)

Maximum sample rate upsampling

Oversampling 2x only

Some CPUs may not be able to perform sample rate conversion at best
quality settings fast enough for realtime playback.

This could result in pauses in playback.

Note that changes will be effective only upen next playback start.

Audio Signal Polarity

[ | Invert globally
[E Invert for tracks with INVERTPOLARITY comment

Audio Filters window



® Audirvana Plus File Edit Play Window Help
enon Audirvana Preferences

(1] o X

General Audie System  Audio Filters

- @

SysOptimizer iTunes.

Volume control type: (s) DAC only &
) DAC if available, else software
() Software only

~
Max. volume level: < )| o0.0|d8
o 100%

Note that changes will be effective only upon next playback start.

Audio Volume window

# AudirvanaPlus File Edit Play Window Help
NN Audirvana Preferences

o )

General Audio System Audio Filters Audio Volume

SysOptimizer optimizes OSX for Audio Playback by deactivating non-
essential services that can cause inteferences detrimental to sound
quality.

L3

E Optimize System for Audio Playback

™ Disable Spotlight

E Disable Time Machine

|| Disable detection of iDevices on USB

Selected services are deactivated upon playback start, and restored after
stop.
00:00 B—

SysOptimizer window



Pure Music configuration

Pure Music works only in integrated mode with iTunes:

1. On top Bar click on Pure Music > Audio Setup

& L Edit  Music Server  Metering  NetSend
About Pure Music
= Preferences... i,
vonio_gAudio Setup... 4HA

Add FLAC or DSD Files... ®F
Audio File Sample Rate Converter... k
Convert Audio Files to Apple Lossless... a

Services -

Hide Pure Music
Hide Others THEH
Chow All

Quit Pure Music ¥Q

{C}} Recenti

2. In Device Selection verify is selected PCM-DSD USB Audio Interface as output

o Pure Music Edit Music Server Metering NetSend
s
= s
Monitor
Nue D ALkl IDienin i Generi [ Playlis
SAE: 2
l PEATSCTN  Audio Plug-Ins |-
[ 3 # Select Device From Application [ Strict Device Validati
sta Albu:
—m Input and Playthrough | Special Options )—
Output Device Integer requires Memory Play, Preallocate and Supported Device
| PCM-DSD USB Audio Interface s | 384 kHz =
Current: PCM-DSD USB Audio Interface Target: 384000
HW Vol
Allow Device Hardware Control If Supported: E] Volume [51 Mute
Invert # Enable Exclusive Access ("Hog" Mode) | | ot inieoer formar Sunpert

DSD Praferred Equivalent PCM Playback Rate (Maximum): | 352.8kHz

The output device selected in Audio MIDI Setup cannot be used with Hog mode.
Current Device and Target sample rate are only updated at launch time.

| Click to Apply Changes (Application Will Relaunch) | | special... |

| Close |




3. To play dsd file go on Special Options and check DSD streaming Device option. In
addition set DSD flag to 05FA so the DAC can recognize the file correctly.

® Pure Music Edit Music Server Metering NetSend

: .ﬂ« P bpr oo ‘

Mute | Dim Audio Setup t Gener m
.
l e Audio Plug-Ins |-
[ 3 # Select Device From Application [ Serict Device
) ) sta Albu
| Output | Input and Playthrough [BEiZaEIRe i
: Special Options Read Description in User Guide Before Changing Settings
MOTU Traveler Secondary Output Streams
Limit Rate: | 384 kHz &
HW Val
Inveri ~ DSD Setup CAUTION - Read Description in User Cuide Before Changing Settings!

Copy Current Output Device Name ]

Press the Click to Apply Changes Button to Finalize Device
Flag: () ARAA () O5FA

The output device selected in Audio MIDI Setup cannot be used with Hog mode.
Current Device and Target sample rate are only updated at launch time.

| Click to Apply Changes (Application Will Relaunch) | | Special... |

| Close |

4. For DSD file memory play option must be enabled, so verify is green lit on side bar.
Then go in Pure Music > Preferences

(" Pure Music R3¢0 Music Server Metering NetSend
About Pure Music

Preferences... 8,
Audio Setup... THA |
Add FLAC or DSD Files... ¥F
Audio File Sample Rate Converter... b
Convert Audio Files to Apple Lossless. .. a

Brani A

Services p |

Hide Pure Music

Hide Others TEH

Show All

Quit Pure Music ¥0
i 2

HW Val {é} Recenti



5. In Music Server Settings > Advanced you must enable Preallocate mode in Memory
Play Optimization.

® Pure Music Edit Music Server Metering NetSend

I«Pbb—\'_) ‘

Monitor
Preferences pr————
Mute  Dim
+ Processing Load: < 1 % t Gener Playlis
=

| Audio Settings PITHSTTISCIEN Registration |

Basic WELEICLEY Special ]—.k
The original, default settings are best for new users. Please read sta Albun
option descriptions in the User Guide before changing settings.

Upsampling

Upsampling Method: @ Maximum Fldelity O NOS Type "Classic”
|| Only Upsample 44.1 or 48 kHz Audio

("] Attempt Only Power-Of-Two Upsampling
[] Always Upsample Redbook to =192 kHz (if supparted by DAC)

HW Vol

Invert

[ Invert Audio Polarity when “invertpolarity” tag is detected
Invert polarity for tracks with the string invertpolarity in the iTunes Comment tag

|| Observe iTunes per-track Volume Adjustment Setting

Memory Play Optimizations

@I Gapless Playback
[QI Hybrid Memory Play @]’ Preallocate Takes effect on next launch

Hybrid and Preallocate are Requirad for Gapless, DSD. and Pure Vinyl Bookmarks.

| Defaults... | | Audio Setup... |

Enable Single-Key Keyboard Commands | Close Preferences




For Windows users we recommend Jriver or the free player Foobar2000.

Jriver configuration

1. Click on Tools > Options

File

Edit View Player

Tools

Help
Import...

AcquireImages..

| Rip Disc...
| Playing Now Burn Disc..,
Audio Advanced Tools 14
» B Albums Send To »
i’ E“ Artists Library Tocls 14
4 !‘ Files Locat; 4
* B Genres Links »
!ﬂ Panes
Eﬁ Recent Albums Language 4
!ﬂ 3D Albums | Options... D(Ztrl+0
v E§ Connected Media T
Images 4
Video r
Performer Store
Podcasts ¥
Playlists 4
Drives & Devices s
Services & Plug-ins 4

2. To play DSD file you have two possibilities:
in Audio Output select Output mode > ASIO

(ASIO is a trademark and software of Steinberg Media Technologies GmbH)

titept Edit

Player

Help

Options

[ 5 Audio

Burning

CD, DVD & BD

L—a Encoding

@ File Location
E_d File Types
h‘.‘-“ General

B Handheld
k‘} Images

i Library & Folders
[5) Media Network
|| Podcast

“{: Remote Control

Lﬂ Services

fay Startup
Television
- Theater View

15 Tree & View

g video

= Audio Output
(+] Qutput mede: ASIO

()| v assio
v Sel Direct Sound

=] Disk Writer

D: Kernel Streaming
| MNull Qutput :

& wasarr [eaded:

@ ASAPI - Event Stvl Ire synchronization: 4 seconds
| WASAPI - Ever ple

i F o ’ i disk (not zone-specific)

Wave Ou

[ brworemepray-rrerrearrmrg-er-{useful for HOMI audic)

- Track Change
(=] Switch tracks: Standard (gapped) - 0,15
Do not pla
Use gapless for sequential alburm tracks
= Stop, Seek & Skip
E Seek: Smooth (normal)
[Z[ Stop: Fadeout (fast]
E Pause: Fade (fast)
(=] Jump behavior: Forward 30 seconds, backward 10 seconds

ilence (leading and trailing)

= Volume
(=] Velume mode: System Volume
D Volume Protection

NOTE: Changes take effect once playback is stopped

QK Cancel

Help




2.1.  In output mode setting verify you have PCM-DSD USB ASIO device

[Pcr-DsD UsE Asi0 [
Channel offset; | 0 More Skip 0,50 seconds More
Resistant Responsive

Channel offset determines which outputs to use on
the selected device, Try different values {0, 2,4, etc) @ Use large hardware buffers (recommended to prevent stutter)
until the audio is routed to the desired cutput.
MNOTE: Increasing buffering makes playback less likely to skip and
Channel swap:  None hd hiccup, but alse increases the time it takes for cross-fades and
smooth-seeks to kick in,

ASIO device names do not always match Windows device names,

Please select the corresponding Windows device for volume control. Open Driver Control Panel...
Volume device: | (Automatically try to choose at playback time) x @ Play silence on pause (instead of performing a hardware level
pause)

@ Dither bitdepth conversions
@ Device uses only most significant 24-bits (Lynx, etc.)

@ Dizplay dizgnostics when starting ASI0

Cancel

=re oK Cancel Help I

In settings click on Bitstreaming format >Custom

h‘_} Audio ~ Audio Output
[ - Buming [>] Output mode: ASIO
D Gutput mode settings...
CD, DVD & BD
 Settings
b Encoding [ DSP & cutput format...
@ File Location Bltstreammg: Yes (_DSDJ .
E_d File Types )| Mone (recommended) znded)
hﬂ D [¥]| s/pDIF & synchronization: 4 seconds
HOMIL disk (not zone-specific)
F Handheld D| + Custom... b 1seful for HOMI audio)
h_'} Images ~ Track Change
| Library & Folders EJ Switch tracks: Standard (gapped) - 01s

= . Do not play silence (leading and trailing)
&:]Medla MNetwork L piay - g 9
Use gapless for sequential album tracks

|| Podcast "

-  Stop, Seek & Skip

\(‘2 Remote Control [ Seek: Smooth (normal)
m Services [] Stop: Fadeout (fast)
m Startup [ZJ Pause: Fade (fast)

D Jump behavior: Forward 30 seconds, backward 10 seconds

@ Television

~ Volume
' Theater View

EJ Volume mode: Systern Volume
ia| Tree 8t View [ velume Protection

kj Yideo MOTE: Changes take effect once playback is stopped

peyour search here 0K Cancel Help




You must select DSD

Options

! |} Audio
‘ ~ Burning

-" CD, DVD & BD
b Encoding
6 File Location
E& File Types
u General

B Handheld
u Images

44 Library & Folders
(&) Media Network
| .| Podcast
\Q Remote Control
i Services
EJ Startup
m Television

- Theater View
15 Tree & View

| Video

~ Audio Output
(] Output mode: ASIO
[ Output mode settings...
~ Settings
DSP & output forma

itstreaming Formats

@ Dolby Digital (AC3)

@ Dolby Digital Plus (E-AC3)
& Dolby TrueHD

8o

@ O7s-HD

& Dsp

=] DSDEH PCM (DoP)

DoP Format: | DoP 1.0 (0xFA / 0x05) |~

Cancel

Volume
[>] Valume mode: System Volume

D Volume Protection

MOTE: Changes take effect once playback is stopped

0K Cancel

Help

| File Edit View Player

Tools

Help

Uptions

2.1. The other possibility is to select Wasapi event style for Vista/Win7/Win8
users or Kernel Streaming for XP ones

| 3 Audio

L Burning

-" €D, DVD & BD
b Encoding

@ File Location
EJ File Types
u General

E Handheld
k; Images

|4 Library & Folders
() Media Network
[ .| Podcast

Q\‘ Remote Control
u Services

w Startup

ﬁ Television

' Theater View

15| Tree 8 View

~ Audio Output
B Output mode: WASAPI - Event Style
G| aso
- Sef Direct Sound
= | Disk Writer .
[ Kernel Streaming

@ r‘\lills?:;put nended)
EJ i ire synchronization: 4 seconds
| % WASAPI - Event Style
. +f disk (not zene-specific
B 5 ot [ i disk (not pecific)
e Oul

[ erworerepray-rrerrraremrg-oruseful for HOMI audic)

¥ Track Change

[>] Switch tracks: Standard [gapped) - 0,15

Do not play silence (leading and trailing)

Use gapless for sequential album tracks
- Stop, Seek & Skip

@ Seek: Smooth (normal)

EJ Stop: Fadeout (fast)

[] Pause: Fade (fast)

[ Jump behavior: Forward 30 seconds, backward 10 secands
~ Volume

Volume mode: Systern Volume

|3 video

D Volume Protection

MOTE: Changes take effect once playback is stopped

oK Cancel

Help




In settings click on Bitstreaming format >Custom and select DSD over PCM

To play PCM files on Vista/Win7/Win8 you can use all Output Mode. For Xp users

[ File Edit View Player Tools Help

O ptions

|} Audio
[ Burning
CD, DVD & BD

h Encoding

6 File Location
Elj File Types
u General

¥ Handheld
h‘; Images

|4 Library & Folders
| Media Network
E | Podcast

% Remote Control
m Services
m Startup
Television
- Theater View
EE.'_‘J Tree 8 View

g3 video

~ Audio Output
E] Output mode: WASAPI - Event Style
[ Cutput mode settings...
¥ Settings
. DSP & output format..,

Bitstreaming Formats
@ Dolby Digital (AC3)
@ Dolby Digital Plus (E-AC3)

@ Dolby TrueHD

@ oms

@ DTS-HD

@ osp

B DSD over PCM (Dop]b

DeP Format: | DoP 1.0 (0xFA / 0:05)  |»

Cancel

* Volume
[] Volume mode: System Yolume
[ Yolume Protection

MOTE: Changes take effect ence playback is stopped

oK Cancel

Help

instead use kernel Streaming.

When you use Kernel Streaming you will find North Star Design srl streaming as

output device.

| File Edit View Player Tools Help

Options,

k_g Audio

# Burning

' CD, DYD & BD

3 Encoding

& File Location
EJ File Types
|ig General

Handheld
g images

\y Uibrary & Folders
() Media Network
|1, Podcast

Q\‘.‘ Remote Control
u Services
w Startup
Television
EA theater view

i=| Tree & Yiew

k_.] Yideo

- Audio Output
B Output mode: Kernel Streaming

Kernel Streaming Setlings.

Device: | Morth Star Design srl Streaming

=

More Skip 1,00 seconds More
Resistant Responsive

MNOTE: Increasing buffering makes playback less likely to skip and hiccup, but also
increases the time it takes for cross-fades and smooth-seeks to kickin,

Kernel streaming device names do not always match Windows device names,
Flease select the corresponding Windows device for volume contral.

Volume device: | (Automatically try to choose at playback time)

Cancel

NOTE: Changes take effect once playback is stopped

Ok Cancel

Help




3. Go on DSP&output format and set Output Format in this way:

DSF Studio =5 =2

[ output Format Output Format
Opti

[ velume Leveling Mot enabled (use checkbox on left to enable] Kpkiofs
[ equalizer
[ Parametric Equalizer Sound can blkutput inany format. For example, you can listen to an audio CDin 5.1 surrcund at 22-bit / 192 kHz. Advanced settings like multi-channel
0] erfecte output or high sample rates require a sound card capable of these modes,
[ Hesdphones Sample rate (maore infa) Channels [more info)
O Tempo & Pitch Click in the output column to select a sample rate for each input sample Chinnels: | Stircanimberat channale -
[ Room Correction rate, Right-click to st all at once.

O convolution . T
[ Parametric Equalizer 2
Al Less than 44,100 Hz Me change
Analyzer o
44,100 Hz Mec change Mixing:
48,000 Hz Mo change
88,200 Hz Mo change
98,000 Hz Mo change
176,400 Hz Mo change
192000 Hz . Subwoofer (more info)
Processed in order listed {drag Greater than 192,000 Hz M change ‘When source has no subwoofer (CD audic, etc.) and 'Channels’
to reorder} selection includes a subwoofer:
Manage Plug-ins. Bitdepth (more info)
Bitdepth: | Source bitdepth -
Flat line overflows >
Peak Level: nfa Source:r nfa Internal: nfa

Help

4. If you want be sure not to miss the beginning of a track use the option play silence
at startup for hardware synchronization and set 4 seconds

[BEE e Vi) Player ook Help

Options

g Audio ~ Audio Qutput
(=) Qutput mode: ASIO

. Burmnin
k ]
=] Qutput mode settings...

CD, DVD & BD
* Settings

hﬁ Encoding [2J) DSP & cutput format...
6 File Location D Bitstreaming: Yes (DSD)
E.d File Types rebuffering: 6 seconds (recommended)
[+] Play silence at startup for hardware synchronization: 4 seconds
& General ey R AR : e
M| none I instead of disk (not zone-specific)
B Handheld O 1/4second irning off (useful for HDMI audic)
k_j Images > Tre 1/2 second
1 second Ly
4 Library & Folders H (gapped) - 012
~ Fsecands pding and trailing)
) Media Network 3 ceconds prng g

itial album tracks
i

| Podcast | w4 seconds
- T St 5econds b
\):; Remote Control EJ‘ & seconds I
= =l B
m Services ﬁ_l; 7 seconds
m Startup [+ 8seconds
[ 9seconds [d 30 seconds, backwerd 10 secands
Television | s "
- Vol 10 seconds
- Iheatenview B Volume mode: System Volume
s Tree & View [ volume Protection
b Vided NOTE: Changes take effect once playback is stopped

oK Cancel Help




Foobar2000 configuration

1. Click on File > preferences

: E File | Edit View Playback Library
Open... Ctrl+Q
Open audio CD...

Add files...

Add folder...

Add location... Ctrl+U
Mew playlist Ctrl+N
Load playlist...

Save playlist... Ctrl+5

Preferences h Ctri+P

2. To play PCM files go on Components and check you have installed Wasapi output
support (Vista/Win7/Win8 users) or Kernel Streaming Output (Xp users):

(5 focbar20 V124 TR .o e —
3 = — 3 -

|-E File Edit View Playbsck Lbrary Help (] (> 1 [ B 1D | ——

[ Preferences: Components

- Components I lled t Right-lick a component for additional options. |
A D!splay MName ’ Version Module
i Context Menu T ’
!'> Default User Interface Album List 4.5 foo_albumlist
.- Keyboard Shortcuts ASIO support 127 foo_out_asio
- Media Library CD Audio Decoder 3.0 foo_cdda
Metworking Converter 1.5 foo_converter
4 -Playback Default User Interface 0.9.5 foo_ui_std
.- DSP Manager Equalizer 10 foo_dsp_eq
4 - Qutput File Operations T2 foo_fileops
. ASIO Virtual Devices foobar2000 core 1.2.4 Core
- Shell Integration Kernel Streaming Output 122 foo_out_ks
4. T?0|5 Online Tagger 0.7 foo_freedb2
i~ SACD ReplayGain Scanner 22 foo_rgscan
I+ Tagging Standard DSP Array 1.2 foo_dsp_std
-~ Advanced Standard Input Array 1.0 foo_input_std
Super Audio CD Decoder 0.6.3 foo_input_sacd
WWASAPI output support 3.2.3 foo_out_wasapi
ZIP/GZIPRAR. Reader 1.6 foo_unpack

Get more components
Why are some components grayed out? ’ Install... ] ’ Copy report ] ’Get updates ]

Resetall | Reset page | | OK. | Cancel [ Apply

T —— e —




3. Go in output and verify is selected Wasapi(event): PCM-DSD USB Audio Interface
or KS: North Star Design srl Streaming:

o 2 e —. e —

File Edit View Playback Library Help

+— Components
-Display
- Context Menu
|+ - Default User Interface
- Keyboard Shorteuts
-Media Library
Networking
-Playback
E---DSP Manager
4 | Qutput |
- ASIQ Virtual Devices
- Shell Integration
-Tools
\-SACD
[» - Tagging
- Advanced

Device

[WASAPI (event) : Uscita digitale (PCM-DSD USB Audio Interface)

Buffer length

—
1940 ms

‘Warning: setking oo low buffer length may cause some visualization effects to stop working,

Output format

Output data format: | 32-bit

- ] [l pither

Refer to your hardware spedfications for preferred output bit depth; using bit depth above your
hardware capabilities will only resultin degraded performance.

Vista/Win7/Win8 users

: fmbar_

File Edit View Playback Library Help [ [=> [1 K [ [# i| I3

Preferences: Output

L ——

- Components Device
4 Diplay : :

.. Context Menu [KS + North Star Design srl Streaming - ]

|+ - Default User Interface
- Keyboard Shortouts Buffer ]ength
[ -Media Library
: Metworking

Pl:aybadi 1940 ms

‘ gil;::nager ‘Warning: setting too low buffer length may cause some visualization effects to stop working,

ASIO Virtual Devices

- Shell Integration Output format
4 -Tools Output data format: | 32-hit ~] [pither
..... SACD
N ey Refer to your hardware specifications for preferred output bit depth; using bit depth above your
Ad ggd 9 hardware capabilities will only result in degraded performance.
- Advance

[ Resetat | [Resetpage o J [ concd [ aomr ]

Xp users



5. To play DSD file go on Foobar components website
http.//www.foobar2000.org/components and search ASIO support 1.2.7 or newer.

Download foo_input_sacd-0.6.3.zip or newer from website:
http.//sourceforge.net/projects/sacddecoder/files/foo_input_sacd/

Download ASIOProxylinstall-0.6.1.zip or newer from website:
http.//sourceforge.net/projects/sacddecoder/files/foo_dsd_asio/

6. For Asio support you just open it and foobar ask if you want add it to other
components.

To install foo_input_sacd open .zip file take foo_input_sacd.dll file and just drag it to
the components window in foobar and click “apply”.

In File > Preferences > Components you will find these new components

File Edit View Playback Library Help RN ERE] [}? |
- ™
Preferences: Components | ? % |
- Components Installed components: Right-dick a component for additional options.
¥ -~ -~
A D!splay Version
i Context Menu e
-Default User Interface L
- Keyboard Shortcuts rd
i
] -Media Library e
i Networking L5
4 -Pl_ayback 0.9.5
i DSP Manager 1.0
4 -O_utput 2.2
- ASIO Virtual Devices 1.2.4
- Shell Integration 1.2.2
4 -T_ools 0.7
i GACD 2.2
> - Tagging 2
-~ Advanced 1.0 foo_input_std
Super Audio CD Decoder 0.6.3 foo_input_sacd
WASAPI output support 3.2.3 foo_out_wasapi
ZIF/GZIF jRAR Reader 1.6 foo_unpack
Get more components
Why are some components grayed out? I Install... ] ’Ccpy report‘ [Get updates ]
Reset all Rezet page Cancel Apply

Then open ASIOProxylinstall-0.6.1.exe in the same Zip file and wait installation
complete.


http://www.foobar2000.org/components
http://sourceforge.net/projects/sacddecoder/files/foo_dsd_asio/
http://sourceforge.net/projects/sacddecoder/files/foo_dsd_asio/ASIOProxyInstall-0.6.1.zip/download
http://sourceforge.net/projects/sacddecoder/files/foo_input_sacd/

7. Now under Output you will find ASIO Virtual Devices. Click on Add new > Driver
and choose foo _dsd_asio:

File Edit View Playback Library Help ‘O KB .
Preferences: ASIO Virtual Devices | @l 23 |
ASIO Virtual Device Editor =]

Mame: foo_dsd_asio

Driver: |foo_dsd_asio - ] [ Configure ]

Channel Map (dick to edit)

Device channel Format Mapping et
Sample DsD Left ‘
Sample DsD Right E
Sample DsD <none =

Sample DsD <none = Ti
Sample DsD <none =

Sample DsD <none =

Sample DsD <none =

Sample DsD <none = 1)
:_\"_I_ r‘mrn — |

OK ] [ Cancel

[ Add New J [ Edit ] [ Remove ]

8. Click on configure and set Asio Driver as ASIO PCM-DSD USB, DSD playback
method as ASIO native

- =)

ASIO Driver: IRSID PCM-DSD USB

DSD Playback Method: [ASIO Native

PCM to DSD Method:  |None




9. Go in Tools > SACD and select DSD in ASIO driver mode

File Edit View Playback

Library

Help |

O MK MR

Preferances: SACD

e —

+ Components
isplay
Context Menu

[ - Default User Interface
- Keyboard Shortcuts
[» - Media Library
- Networking
4 -Playback
DSP Manager

4 - Qutput

. ASIO Virtual Devices

- Shell Integration
4 -Tools

[» - Tagging
- Advanced

2] gx_ﬂ

ASIO Driver Mode:

PCM Volume:

Pov sl

DSDZPCM Mode: [r-uu.-;mge (Fixed-Faint)

- ] !ﬂd_| [_Save |

Preferable Area: Stereo b
Editable Tags
Edited Master Playback

[ o H Cancel H Apply

10. In Output choose foo_dsd_asio device

File Edit View Playback

Library Help

O 0K HE

l

+ Components
Display

|» - Default User Interface
- Keyboard Shortouts
[ -Media Library
- Networking
Playback

DSP Manager

4 Output

. ASIO Virtual Devices

- Shell Integration
4 -Tools

[» - Tagging
- Advanced

Buffer length

0
1940 ms

‘Warning: setting too low buffer length may cause some visualization effects to stop working,

Output format
Oukbput data Farmat: v | [ pither
Output data format will be chosen automatically for the selected device,
[ ok | ’ Cancel ] | Apply




